Skip to main content
← All vulnerabilities
CVE-2022-3978GHSA-5GWX-WF9G-R5MX

NodeBB abort cross-site request forgery

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.5.8
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

A vulnerability, which was classified as problematic, was found in NodeBB up to 2.5.7. This affects an unknown part of the file /register/abort. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 2.5.8 is able to address this issue. The name of the patch is 2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-213555.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • unspecified NodeBB

    2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5, 2.5.6, 2.5.7

  • nodebbnpm

    fixed in 2.5.8

References 4

GitHub · NodeBB/NodeBB

vuldb.com