Skip to main content
← All vulnerabilities
CVE-2022-39361

Metabase vulnerable to Remote Code Execution via H2

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.41.9, 0.42.6, 0.43.7, 0.44.5, 1.41.9, and 3 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9, H2 (Sample Database) could allow Remote Code Execution (RCE), which can be abused by users able to write SQL queries on H2 databases. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase no longer allows DDL statements in H2 native queries.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • metabase metabase

    fixed in 0.41.9; From 0.42.0 · fixed in 0.42.6; From 0.43.0 · fixed in 0.43.7; From 0.44.0 · fixed in 0.44.5; From 1.0.0 · fixed in 1.41.9; From 1.42.0 · fixed in 1.42.6; From 1.43.0 · fixed in 1.43.7; From 1.44.0 · fixed in 1.44.5

References 1

GitHub · metabase/metabase