Skip to main content
← All vulnerabilities
CVE-2022-39315GHSA-C27J-76XG-6X4F

Kirby CMS vulnerable to user enumeration in the brute force protection

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.5.8.2, 3.6.6.2, 3.7.5.1, 3.8.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • getkirby kirby

    fixed in 3.5.8.2; From 3.6.0 · fixed in 3.6.6.2; From 3.7.0 · fixed in 3.7.5.1

  • getkirby/cmsPackagist

    fixed in 3.5.8.2

  • getkirby/cmsPackagist

    From 3.6.0 · fixed in 3.6.6.2

  • getkirby/cmsPackagist

    From 3.7.0 · fixed in 3.7.5.1

  • getkirby/cmsPackagist

    From 3.8.0 · fixed in 3.8.1

References 5

GitHub · getkirby/kirby