Skip to main content
← All vulnerabilities
CVE-2022-39231GHSA-R657-33VP-GP22BIT-PARSE-2022-39231

Parse Server subject to Improper Authentication allowing Auth adapter app ID validation to be circumvented

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.10.16, 5.2.7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 4.10.16, or from 5.0.0 to 5.2.6, validation of the authentication adapter app ID for Facebook and Spotify may be circumvented. Configurations which allow users to authenticate using the Parse Server authentication adapter where `appIds` is set as a string instead of an array of strings authenticate requests from an app with a different app ID than the one specified in the `appIds` configuration. For this vulnerability to be exploited, an attacker needs to be assigned an app ID by the authentication provider which is a sub-set of the server-side configured app ID. This issue is patched in versions 4.10.16 and 5.2.7. There are no known workarounds.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • parse-community parse-server

    fixed in 4.10.16; From 5.0.0 · fixed in 5.2.7

  • parse-servernpm

    fixed in 4.10.16

  • parse-servernpm

    From 5.0.0 · fixed in 5.2.7

References 1

GitHub · parse-community/parse-server