Skip to main content
← All vulnerabilities
CVE-2022-3793

An improper authorization issue in GitLab CE/EE affecting all versions from 14.4 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.3.5, 15.4.4, 15.5.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

An improper authorization issue in GitLab CE/EE affecting all versions from 14.4 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2 allows an attacker to read variables set directly in a GitLab CI/CD configuration file they don't have access to.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • GitLab GitLab

    From 12.6 · fixed in 15.3.5; From 15.4 · fixed in 15.4.4; From 15.5 · fixed in 15.5.2

References 2

gitlab.com