CVE-2022-37734GHSA-V62J-CXHH-FQ22
graphql-java before19.0 is vulnerable to Denial of Service.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 17.4, 18.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
graphql-java before19.0 is vulnerable to Denial of Service. An attacker can send a malicious GraphQL query that consumes CPU resources. The fixed versions are 19.0 and later, 18.3, and 17.4, and 0.0.0-2022-07-26T05-45-04-226aabd9.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- com.graphql-java:graphql-javaMaven
fixed in 17.4
- com.graphql-java:graphql-javaMaven
From 18.0 · fixed in 18.3