Skip to main content
← All vulnerabilities
CVE-2022-36087GHSA-3PGJ-PG6C-R5P7PYSEC-2022-269

OAuthLib vulnerable DoS when attacker provides malicious IPV6 URI

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.2.1, 3.2.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

OAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. In OAuthLib versions 3.1.1 until 3.2.1, an attacker providing malicious redirect uri can cause denial of service. An attacker can also leverage usage of `uri_validate` functions depending where it is used. OAuthLib applications using OAuth2.0 provider support or use directly `uri_validate` are affected by this issue. Version 3.2.1 contains a patch. There are no known workarounds.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • oauthlib oauthlib

    From 3.1.1 · fixed in 3.2.1

  • oauthlibPyPI

    From 3.1.1 · fixed in 3.2.2

  • oauthlibPyPI

    From 3.1.1 · fixed in 3.2.1

References 9

GitHub · oauthlib/oauthlib

lists.fedoraproject.org