Skip to main content
← All vulnerabilities
CVE-2022-35980GHSA-F4QR-F4XX-HJXW

OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.0.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

OpenSearch Security is a plugin for OpenSearch that offers encryption, authentication and authorization. Versions 2.0.0.0 and 2.1.0.0 of the security plugin are affected by an information disclosure vulnerability. Requests to an OpenSearch cluster configured with advanced access control features document level security (DLS), field level security (FLS), and/or field masking will not be filtered when the query's search pattern matches an aliased index. OpenSearch Dashboards creates an alias to `.kibana` by default, so filters with the index pattern of `*` to restrict access to documents or fields will not be applied. This issue allows requests to access sensitive information when customer have acted to restrict access that specific information. OpenSearch 2.2.0, which is compatible with OpenSearch Security 2.2.0.0, contains the fix for this issue. There is no recommended work around.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • opensearch-project security

    From 2.0.0.0 · through 2.1.0.0

  • org.opensearch.plugin:opensearch-securityMaven

    From 2.0.0.0 · fixed in 2.2.0.0

References 3

GitHub · opensearch-project/security